[OS][4.4.2] Portierung des CyanogenMods 11.0 fürs Ace 2-P

  • 136 Antworten
  • Neuster Beitrag
notbremse

notbremse

Erfahrenes Mitglied
Hallo,

die Umstellung auf ART habe ich gemacht und du hast richtig vermutet:
Speicherplatz waren nur noch 187 kB.
Nachdem meine Frau ihr Smartphone auch ab und zu benutzen will, habe ich jetzt erst mal wieder auf Dalvik umgestellt.
Ob ich mich an die Umpartitionierung traue, weiß ich noch nicht.
Dann ist wohl diese Anleitung zu befolgen?
https://www.android-hilfe.de/forum/anleitungen-fuer-samsung-galaxy-ace-2.1530/repartitionierung-des-nand-flash-chips-fuer-eine-bis-zu-3-gib-grosse-datenpartition.596137.html
Ich habe zwar schon mal von ADB etc. gehört, aber trotzdem habe ich Angst hier etwas zu verhauen.

Muss ich das machen bevor ich auf ART umstellen?
 
Zuletzt bearbeitet:
Ace2nutzer

Ace2nutzer

Stammgast
Ja.. zuerst ist besser zu umpartitionieren ...

Und Du brauchst keine Angst zu haben wenn Du dich an meine Anleitung hältst.
Am besten immer mit Kopieren/Einfügen arbeiten, dann kann man sich auch nicht vertippen. Die Gefahr liegt wirklich nur beim vertippen..

Ansonsten habe ich auch eine .zip erstellt für den ClockworkMod .. die macht genau das selbe wie in meine Anleitung beschrieben.. ist vielleicht für Anfänger noch besser. Ich selbst nutze so etwas nicht, weil ich sehen will was ich tue.. daher ungetestet.. sollte aber klappen.

Findest Du hier:

[Guide] CWM ReParted - Post #53 - XDA Forums

nicht vergessen:

1. NANDroid-Backup anlegen und sdcard0 inhalt auf sdcard1 rüber kopieren (sodass sdcard0+1 alles auf sdcard1 ist (ext-sdcard)
2. repart. siehe link ..
3. Gerät per ClockworkMod herunterfahren
4. in den ClockworkMod booten
5. 18/11 OS (mit f2fs-Unterstützung) einspielen
6. Gerät per ClockworkMod herunterfahren
7. in den ClockworkMod booten
8. formatiere data, system und cache als f2fs und sdcard0 als vfat in cwm
9. restore dein backup im erweiterten Modus und restore alles außer SYSTEM..
10. aktuellen f2fs-Kernel flashen
11. pico uni GApps flashen
12. reboot system
13. swap storages in NT-APP
14. auf ART umstellen.
 
Zuletzt bearbeitet von einem Moderator:
notbremse

notbremse

Erfahrenes Mitglied
Hallo,

jetzt muss ich doch noch einmal nachfragen, da mir nicht 100 % sicher bin, ob mit Punkt 13. swap storages in NT-APP die NovaThor Einstellungen gemeint ist? Und da -> Erweitert -> Tausche Speicher?

Und meine Frau hat nur eine SDHC Klasse 4 mit 4 GB? Das ist ja laut
der Repartitionierungs-Anleitung:
"Ach ja: natürlich ist die Voraussetzung das ihr eine Class 10 sdcard habt"
nicht ausreichend
Mir ist klar, das SDHC so gut wie nichts mehr kosten, aber gibt es evt. auch eine andere Möglichkeit?

Danke und VG
 
Ace2nutzer

Ace2nutzer

Stammgast
@up

Ja richtig !

Habe hier auch eine class 4 mit 8GB .. und damit geht's auch.. ist halt ein wenig langsamer als Class 10 .. aber Sinn und Zweck wird damit auch erfüllt! :)
 
notbremse

notbremse

Erfahrenes Mitglied
Hallo,

ich habe mich an deinen Plan gehalten. Allerdings kam zwischendurch die Meldung E: Can't mount /verschiedene Ordner
und beim restore: Error while restoring /storage/sdcard0/.android_secure!
und bleibt jetzt beim hochfahren beim Logo: Samsung Galaxy Ace 2 GT-I8160P hängen.
Soll ich die ganze Prozedere noch mal durchmachen? Liegt es vielleicht doch an der 4 GB Karte??
Ich seh mich schon ein neues Handy kaufen:scared:
 
Ace2nutzer

Ace2nutzer

Stammgast
Dann hast Du wohl diesen Schritt hier übersehen:

8. formatiere data, system und cache als f2fs und sdcard0 als vfat in cwm
Also dann hier weiter machen:

f2fs Kernel installiert ?? - falls ja ..

Bei "mounts and storages" siehst Du ein Menüpunkt: "Toggle f2fs Conversation Migration" o.ä. .. dass mal auswählen .. sodass dort steht: "Enabled".

Dann wie gesagt:

Wähle "format system" dann als "f2fs" (es geht nicht aut. ! Du musst es schon auswählen.. sonst --> ext4 !!)

Das selbe mit "foramt cache" und "format data" ...

Dann "format sdcard0" und wählst aus wie gesagt: "vfat" ..

Jetzt nochmal versuchen Dein Backup zu restoren ;-)
 
notbremse

notbremse

Erfahrenes Mitglied
Hallo,

ja habe ich alles so gemacht. Hat mir auch eine unruhige Nacht beschert, denn eigentlich wollte ich nur das Handy meiner Frau beschleunigen.
:thumbdn:
Habe es sogar heute, bevor ich zur Arbeit gegangen bin, noch einmal versucht. -> Selbes Resultat!
Der Fehler tritt beim Restore des Cache (Error while restoring /storage/sdcard0/.android_secure!) auf, alles andere läuft jetzt ohne Probleme durch.
Am Schluss teilt mir CWM immer mit, dass das Smartphone nicht gerootet sei und ob ich das will.
Kann es daran liegen?
Was passiert, wenn ich das Backup nicht einspiele?
Oder wie bekomme ich wieder ein lauffähiges Ace 2 hin? Kann ich einen anderen Weg gehen?
Zuerst wieder zurück auf ext4?
Tut mir leid, daß ich Dich so beschäftige!
Aber ich hoffe, dass Du noch eine Lösung weißt.
 
Ace2nutzer

Ace2nutzer

Stammgast
Hallo, formatiere bitte alles wie gehabt erneut: data, system und cache als f2fs und sdcard0 als vfat und beim restoren (advanced restore) spielst du nur zurück: data und falls das backup von der 18/11 sein soll, dann auch: system

Ansonsten nur data dann hinterher die 18/11 mit f2fs Bezeichnung flashen dann pico uni-gapps und mein aktuellen f2fs kernel...(20150115 test1) zu finden auf xda in ein post von mir.. Oder eben direkt in mein ftp Server schauen (nicht im dev-host)

Damit muss es 100% gehen.. Und die Frage: dass daa Gerät nicht gerootet sei, sollte nicht kommen, aber Grundsätzlich nein auswählen da CM 11 bereits gerootet ist
 
notbremse

notbremse

Erfahrenes Mitglied
Hallo,

habe mich an Deine Anleitung gehalten, zuerst formatiert. Dann nur das Backup von Data eingespielt. Dabei habe ich wieder die Fehlermeldung "Error while restoring /storage/sdcard0/.android_secure!" erhalten.

Dann zuerst 18/11, Gapps und den Kernel vom 15.01. eingespielt. Habe allerdings den ohne Test 1 genommen, da der schon auf der SD Karte war. Soll ich den Test 1 noch per CWM updaten? Wenn ja, muss ich da etwas beachten?
Dann reboot, swap storage und auf ART umgestellt.

Die externe Speicherkarte wird mit nur noch 9,98 MB angezeigt, die restliche Speicherbelegung habe ich als Screenshot beigefügt. Ist das alles im grünen Bereich?
Kann ich das mit CWM erstellte Backup löschen?
Arbeitsspeicher ist mit 555 MB angegeben.
Wenn ich es richtig verstanden habe, dient die ext. Karte jetzt als zusätzlicher Gerätespeicher. Wenn ich jetzt eine größere zur Verfügung habe, tausche ich dann nur wieder den Speicher und setze die größere ein?

Nochmal vielen, vielen Dank für Deine Hilfe.
 

Anhänge

Zuletzt bearbeitet:
Ace2nutzer

Ace2nutzer

Stammgast
Soweit alles okk.. Ausser die sdcard0 .. Mit 10mb.. Ist immer noch nicht als vfat formatiert.. Deswegen klappt es mit dem backup ja nicht.
So wies jetzt ist darfst du die sdcard nur herausnehmen und wechseln wenn das Phone ausgeschaltet ist. Grössere und daten von der alten sd rüber kopieren.

Ja test 1 aktuell empfohlen. Läuft auch stabil über 1ghz. Und Verbesserung im ram management..
Ist quasi ein Vorgeschmack.. Maximale Stabilität + perfekter RAM Management gibt es im nächsten offiziellen build von mir..

Edit: wenn du von vorne beginnen willst: alles einrichten etc.. Dann kannst du auch das Backup löschen... Wenn du data zurück spielst sind die alten apps + Einstellungen wieder da.
 
notbremse

notbremse

Erfahrenes Mitglied
Okay, dann soll ich die SD-card 0 noch nachträglich im CWM formatieren? Oder wieder von vorne?
Ich hoffe, dass ich es irgendwann begreife...
 
Ace2nutzer

Ace2nutzer

Stammgast
Ich schreibe von Anfang an: und sdcard0 als vfat ...

Damit ist der interne Speicher gemeint.. Und nicht deine richtige sdcard1
 
notbremse

notbremse

Erfahrenes Mitglied
So jetzt habe ich das ganze mit einer 16 GB Speicherkarte komplett von vorne durchgeführt. Ergebnis: Bleibt beim Samsung Logo hängen. Die übliche Fehlermeldung bei Restore der Data kam wieder. Die sdcard wurde übrigend als vfat formatiert, Bild anbei.

Dann zum laufen gebracht, aber wieder nur ~ 10 MB Speicher

Ist es möglich, das etwas mit dem Backup nicht in Ordnung ist?
Oder an der verwendeten CWM-Version 6.0.4.9?
Wieviel sollten es statt der 10 MB wirklich sein?
 

Anhänge

Zuletzt bearbeitet:
Ace2nutzer

Ace2nutzer

Stammgast
Das sieht alles richtig aus... Nur ich sehe dort keine Fehlermeldung.. Du hast dort alles richtig formatiert.. Und hast dann "boot" erfolgreich restored.. Du sollst aber "data" restoren.. Dann die cm11 flashen, dann pico uni-gapps und direkt hinterher den aktuellen f2fs Kernel.. Damit muss es booten.. Oder du macht weiterhin ein Fehler.. Klar es kann auch sein dass das Backup jetzt fritte ist.. hatte ich aber noch nie gehabt.

Ja 10mb ist richtig.. Haben wir so formatiert.. Dafür gibt es ja die 16gb karte z.b. . ... Kannst auch sdcard0 mit 1gb belassen.. Aber dann hast du nur 1.8gb auf /data statt 2.8gb .. ;-).. So ist schon perfekt.. Dann hat man den max. Platz auf /data um so viele Apps wie möglich installieren zu können.
 
notbremse

notbremse

Erfahrenes Mitglied
Hallo Ace2nutzer,

habe bei Xda gesehen, dass du einen neuen Kernel online gestellt hast. Kann ich den einfach über CWM flashen oder muss ich etwas beachten?

Danke und VG
 
Ace2nutzer

Ace2nutzer

Stammgast
Einfach ohne alles flashen ... (in CWM ja .. )
 
S

Sus_i

Neues Mitglied
Ace2nutzer schrieb:
Einfach ohne alles flashen ... (in CWM ja .. )
Hallo Ace2nutzer

Ich komme von den tc rox/poppmensa builds mit standart tc kernel und habe gestern mein codinap umgestellt...

Zuerst mittels deines repart zip von xda auf max speicher partitioniert, f2fs formatiert und dann clean install der cm11 11/18 f2fs, danach pico uni sowie deinen Kernel codinap_kernel_cm11_20150204_f2fs_ace2nutzer.

Das ging problemlos. :thumbsup: Data habe ich nicht eingespielt. Switch auf ART war problemlos. NT-App Speicher geswitcht. CPU ist bis 1200 Mhz Antutu stabil (ohne UV).

Vorher mit den rox/poppmensa builds & tc kernel kam ich ohne reboot auf 1250 (mit UV -65mv). Würde mich interessieren ob ich noch höher takten könnte , vielleicht hast du eine Idee was man in Bezug auf die CPU vcore steps umstellen könnte... bzw. in wie weit sich die orig. tc vcore steps bei 1250 von deinen Einstellungen in oben genannten Kernel unterscheiden!?

Ach ja, Problem habe ich auch bei manchen Apps, Install bricht ab mit Fehler "wurde nicht installiert" egal ob art oder dalvic.

Viele Grüße :thumbup:
 
Ace2nutzer

Ace2nutzer

Stammgast
Hi,

das is schön zu lesen :-D

Bei den TC Builds von Rox war früher der 1250Mhz Step nicht real 1250Mhz .. sondern nur 1228Mhz oder sowas ... bei meinem Kernel ist es real 1250Mhz .. deshalb dann bei 1200Mhz schluss ist. Was Vcore angeht, brauchst Du dir keine Gedanken zu machen.. es ist bereits UV und OV zu selben Zeit.. Natürlich gibt es Unterschiede zwischen den Kernels bei den Spannungen.. aber in meine aktuellen Build is die derzeit max. Stabilität beim OC gegeben .... ich arbeite aber dran es ein wenig stabiler zu machen..... sodass Du evtl. u.U. dann doch auf 1250Mhz kommst und mit viel Glück sogar 1300Mhz :)
 
S

Sus_i

Neues Mitglied
Ok, alles klar, Danke Dir. :smile:

Was denkst du zu meinem Problem das sich größere Apps nicht installieren lassen und mit Fehler "Wurde nicht installiert" abbrechen? Manche Apps verweigern auch den Start mit "Wurde beendet"

Problem mit dem NT App SDCard Switch?

Mal den 2015.02.02.p1 Kernel testen?

-----

Ach ja, noch was fällt mir ein, wie schafft man in antutu 13k? Ich komme auf 11500 (mit 1200mhz, mali auf 720, autoboost gov & performance settings wie in deinem kernel thread in post3 vorgeschlagen).
 
Zuletzt bearbeitet:
Ace2nutzer

Ace2nutzer

Stammgast
Immer den aktuellen Kernel flashen.. niemals ein älterer .. es sei denn es gibt einen größeren Bug.. dann empfehle ich natürlich auf ein Build zurück zu gehen.. Es gibt viele Leuten meinen zu müssen ältere Builds sind besser.. doch dann verpasst man unzählige verbesserungen in Sachen Performance und Akkulaufzeit.. (zumindest in mein Kernel)

@ sdcard Problem.. wie gesagt aktuellen KErnel flashen.. schau mal im Thread vorbei was es so gibt :) Ich kann es von hier aus nicht sehen was das Problem sein könnte.. evtl. zu wenig Speicher ?? Check mal unter ----> Einstellungen ---> Speicher... alles Balken ob genug frei ist ... das erste is für Apps, das zweite ist der interne Speicher (oder eben sd-card fallls vertauscht) dann sd-card (oder eben interne Speicher falls vertauscht) alle 3 Balken müssen noch genügend Platz frei haben.. (so 20% frei wär nicht schlecht)

@ Antutu .. ich hoffe Du hast die aktuelle Version von Antutu ?! Es gibt keinen Trick für die 13k .. mal schaff ich sogar 13580 Points. Einfach alles auf default.. Phone neustarten .. und 5 minuten warten damit der Kernel alles erledigt hat.. und somit nix mehr zu tun hat...

Dann in NT-APP Mali zugeteilter Speicher auf 32MB... und Mali auf 720Mhz hoffentlich nicht über NT-APP oder ?! Denn damit gehtz leider nicht (mehr)

Du musst das File bearbeiten in /system/etc/init.d/01optimization ...dort alles angucken.. dann weisst Du das du einen Wert ändern musst... z.b.: echo 691200 ... für 690Mhz u.s.w. .. alles selbst erklärend.. Befor Du es aber abänderst und speicherst.. ist es empfehlenswert den neuen Takt erst einmal auf Stabilität zu testen... und das geht so:

Markiere die komplette Zeile mit echo ....... /mali_boost_high und füge diesen Befehl in den Term. Emulator ... (schwarzes Bildschirm) und ändere eben den Takt ... Läuft dieser stabil.. kannst Du es in der 01optimization File umändern und speichern.

PS: Nicht vergessen im terminal emulator als erstes ein "su" einzugeben .. denn ohne "root" Rechte gehtz nicht ;-)
 
Oben Unten