Google Fotos lässt sich nicht mehr dauerhaft deaktivieren

  • 114 Antworten
  • Neuester Beitrag
Diskutiere Google Fotos lässt sich nicht mehr dauerhaft deaktivieren im Google Fotos im Bereich Foto und Multimedia.
sweetNougat

sweetNougat

Experte
Ehrlich gesagt, ob ich Fotos vorher wieder deaktiviert hatte weiß ich nicht mehr, danach habe ich Debugging wieder ausgeschaltet.
 
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Ich habe nun mal wieder manuell deaktiviert. So ist Fotos aus den Updates verschwunden, aber nicht aus der App-Liste...
Kommt also sicher wieder...
Aber vielleicht kommt ja noch ein Tipp von @BOotnoOB
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Moderator
Teammitglied
@CarlFredricksen Starte das Handy mal neu und dann führst du den Befehl ohne "-k" aus. Also:
Code:
pm uninstall --user 0 com.google.android.apps.photos
 
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
da kommt der gleiche Fehler-Code
 
BOotnoOB

BOotnoOB

Moderator
Teammitglied
@CarlFredricksen Und die App ist noch installiert?
Beitrag automatisch zusammengefügt:

@CarlFredricksen Die App wird in den Einstellungen weiterhin angezeigt, sollte aber den Vermerk "nicht für Nutzer installiert" haben.
Aber im Play Store dürfte sie danach nicht mehr auftauchen.

Du kannst den Befehl auch erst wieder rückgängig machen und es dann nochmals probieren:
Code:
pm install-existing com.google.android.apps.photos
 
Zuletzt bearbeitet:
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Das funktioniert auch nicht. Siehe die Screenshots

Ich habe zwischen dem Installieren-Befehl und dem Versuch zu deinstallieren allerdings das Handy nicht abgestöpselt
 

Anhänge

Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Moderator
Teammitglied
@CarlFredricksen Du musst den Befehl folgendermaßen komplett eingeben:
Code:
adb shell pm uninstall -k --user 0 com.google.android.apps.photos
Beitrag automatisch zusammengefügt:

Oder hast du "adb shell" zu Beginn einmal eingegeben?
Beitrag automatisch zusammengefügt:

Da du nach der Anleitung vorgegangen bist, hast du "adb shell" einmal zu Beginn eingegeben nehme ich an?
 
Zuletzt bearbeitet:
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Hatte ich
Beitrag automatisch zusammengefügt:

Es kommt immer die Fehlermeldung. Ich weiß auch gar nicht, ob Fotos nun installiert ist oder nicht ;-)
Beitrag automatisch zusammengefügt:

Unter "list packages" wird sie aufgeführt...
Das war nach dem ersten deinstallieren, das ja mit "Success" abgeschlossen wurde, allerdings auch so.
Ob es daran liegen kann, dass es ein Blackberry ist?
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Moderator
Teammitglied
Was passiert bei dem anderen Befehl, der es rückgängig macht?
 
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Da kommen die ellenlangen Auflistungen, die in den beiden Screenshots zu sehen sind
Beitrag automatisch zusammengefügt:

Ich habe nun mal testweise auf diese Art eine Drittanbieter-App gelöscht. Das hat funktioniert.
Handy war noch angestöpselt. App ist sowohl auf dem Homescreen als auch in den Einstellungen weg. Im Appstore (in der Suche) taucht sie aber auf, sodass ich sie wieder installieren kann.
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Moderator
Teammitglied
Gib mal ein
Code:
pm list packages -es
Beitrag automatisch zusammengefügt:

Der Befehl zeigt alle Systemapps an, die "enabled" sind.
 
Zuletzt bearbeitet:
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Da kommt:

java.lang.IllegalArgumentException: No argument expected after "-es"
Beitrag automatisch zusammengefügt:

Deaktiviert sind bei mir (dauerhaft) u.a. Play Music, Lens, Rechner, Notizen, Play Filme & Serien, GMail
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Moderator
Teammitglied
@CarlFredricksen Der nimmt nicht beide gleichzeitig... Nimm nur "e".
Beitrag automatisch zusammengefügt:

CarlFredricksen schrieb:
Deaktiviert sind bei mir (dauerhaft) u.a. Play Music, Lens, Rechner, Notizen, Play Filme & Serien, GMail
Laut welcher Info? Einstellungen oder ADB
 
Zuletzt bearbeitet:
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Funktioniert.
Nach was soll ich da suchen?
Beitrag automatisch zusammengefügt:

BOotnoOB schrieb:
@CarlFredricksen Der nimmt nicht beide gleichzeitig... Nimm nur "e".
Beitrag automatisch zusammengefügt:


Laut welcher Info? Einstellungen oder ADB
Einstellungen. Da hatte sich auch nie eine von selbst aktiviert.
Beitrag automatisch zusammengefügt:

Mit dem Befehl "pm list packages -e" werden allerdings auch wiederum alle Apps angezeigt. Also bspw. Threema, Thoman usw.
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Moderator
Teammitglied
@CarlFredricksen Das war jetzt Quatsch, sorry. Hab enabled jetzt verwechselt.

Um zu gucken, ob die App deinstalliert ist, überprüfst du jetzt, ob sie aufgeführt wird
Code:
pm list packages --user 0 com.google.android.apps.photos
Zeigt er die App an, ist sie installiert.
Beitrag automatisch zusammengefügt:

Du könntest als Gegenprobe, falls sie nicht angezeigt wird, vor "--user 0" ein "-u" setzen. Also "...-u --user 0..." Damit werden bei der Auflistung auch alle deinstallierten Apps angezeigt.
 
Zuletzt bearbeitet:
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Wird leider angezeigt.
 
BOotnoOB

BOotnoOB

Moderator
Teammitglied
@CarlFredricksen Ich verstehe das nicht... Der Befehl "uninstall" gibt noch immer einen Fehler?
Beitrag automatisch zusammengefügt:

@CarlFredricksen Führst du cmd.exe als Administrator aus?
 
Zuletzt bearbeitet:
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
Der Befehl gibt noch immer einen Fehler.
Nur als ich es zum ersten Mal gemacht hatte, kam "Success" (so wie beim testweisen deisntallieren der Thomann-App, was ja perfekt geklappt hat, auch mit "-k --user").
Doch mit Fotos funktioniert es nicht.
 
CarlFredricksen

CarlFredricksen

Ambitioniertes Mitglied
ADB3.jpg
Beitrag automatisch zusammengefügt:

BOotnoOB schrieb:
Wenn ich bei mir auf PowerShell (Administrator) gehe, kommt keine Sicherheitsabfrage
Beitrag automatisch zusammengefügt:

Jetzt dämmert es mir langsam. Bei mir steht oben nicht "Administrator:C:\\WINDOWS", sondern nur "C:\\WINDOWS".
Dieses Fenster öffnet sich aber automatisch, wenn ich das Handy anschließe. Gebe ich Windowstaste+x ein, öffnet sich aber doch das Windowseigene Fenster und nicht ADB.
Mit der von dir verlinkten Anleitung, komme ich trotzdem nicht auf Administrator im ADB-Fenster
 
Zuletzt bearbeitet:
Ähnliche Themen - Google Fotos lässt sich nicht mehr dauerhaft deaktivieren Antworten Datum
0
4
6