LineageOS 14.1 GT-N8000 GT-N8010 GT-N8013 GT-N8020 SCH-I915

  • 794 Antworten
  • Neuster Beitrag
html6405

html6405

Gewerbliches Mitglied
Threadstarter
So liebe Leute,

nachdem es mir vor einem Jahr nicht möglich war im Netz ein stabiles LineageOS für
das N8000 zu finden, fing ich an meinen eigenen build zu schaffen...

Es kostete mich bereits intensiv mehrere Monate (jetzt schon über ein Jahr), nun sind sogut wie alle relevanten Fehler ausgebessert
und vieles erweitert / im Kernel angepasst.

Über Tester bzw Rückmeldungen, Beschwerden etc würde ich mich freuen, denn wenn Zeit besteht,
versuche ich jedes Problem zu lösen.

Natürlich haben viele schon Vorabeit geleistet, ohne die Leute auf XDA und ihrem Einsatz wäre das alles natürlich nicht möglich...

Hier nur ein paar hard facts:

Android 7.1.2
SELinux-Status: enforcing (N8000 und N8010)
Kernel: 3.0.101-HTML6405
Sicherheitspatch: 05. Februar 2020
Status: stable
Magisk hide: working
Build-Datum: 25.02.2020

N8000:
ODEXED
Rom:
N8000 Rom
MD5:
N8000 MD5
Deodexed:
Rom:
ROM
MD5:
MD5
TWRP 3.3.1-0 GT-N8000:
N8000 TWRP

N8010, N8013:
ODEXED
Rom:
Rom
MD5:
MD5
TWRP 3.3.1-0 GT-N8010
N8010 TWRP

N8020, I925:
ODEXED
Rom:
Rom
MD5:
MD5
TWRP 3.3.1-0
N8020 TWRP

(Fürs I925 muss die n8020er Version erst von jemanden getestet werden, ansonsten hab ich noch einen eigenen build
fürs SCH-I925)

Bugs beim N8020:
MTP-Crash Bug (MTP funktioniert trotzdem), mount namespace wurde vorübergehend entfernt.
Eingehende Anrufe werden nicht angezeigt, ansonsten stabil und flüssig.

Changelog:
19.02.2020
Da der OTA-Updater-Service nun Geschichte ist,
gibts die Updates ab heute von meinen Server via der internen
LineageOS-Updateapp.
Sicherheitspatch 05.01.2020

17.01.2020
F2FS Support für /data und /cache hinzugefügt, sowohl im TWRP als auch im Rom.


Extras:

GAPPS:
The Open GApps Project (arm)

OTA-Updates:
Updates werden zukünftig via der internen Updateapp von LineageOS durchgeführt.
Also in Einstellungen / Über das Telefon / LineageOS-Updates nachsehen.
Die App überprüft selbst auch automatisch nach Updates.

Hinweis: Um Zram einzurichten, muss eine Swap-App verwendet werden, wie zum Beispiel Swapper.
 
Zuletzt bearbeitet:
Z

zoegge

Neues Mitglied
Sieht sehr spannend aus, werde ich machen. Muss jetzt nach Hause und mit der Kleinen zum Arzt, denke aber dass ich mich heute Abend/Nacht noch einmal diesem Thema widmen werde.

2 Fragen sind bereits jetzt aufgetaucht:

1.) Wurde das einfrieren der Kamera behoben? - 6 jährige Mädchen (sicher auch Jungs) lieben Fotos und Kameras ;-)

2.) sehe ich dass nach der heutigen Aktion richtig, dass ich das OS über Odin einspielen kann - nehme von der Logik von Heute an, dass dies über den Punkt AP laden müsste... oder vertausche ich da was? Bis jetzt habe ich das OS immer über das Customer Recovery geladen.
Soeben haben wir das OS aber über Odin mit geladen oder geht das nicht so einfach wie ich mir das vorstelle?`

Liebe Grüsse und bis später - gebe sicher wieder ein Update wenn ich Dein LineageOS 14.1 drauf habe.
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
zoegge schrieb:
1.) Wurde das einfrieren der Kamera behoben? - 6 jährige Mädchen (sicher auch Jungs) lieben Fotos und Kameras ;-)
Nein, aber man muss nur das Bild öffnen oder die Kameraapp erneut, dann gehts wieder normal.
Im Videomodus tritt das Phenomen nicht auf.

Dieses Problem werde ich mir aber möglichst bald genauer ansehen und wenn möglich lösen.

Zu 2: Das System wird über TWRP eingespielt (3.1.1 empfehle ich),
als erstes unter advanced wipe System und ein factory reset durchführen,
danach einfach installieren und wenn erwünscht, die Gapps (ARM, 7.1.2, micro) im Anschluss.

Lg
 
Zuletzt bearbeitet:
Bearbeitet von Nufan - Grund: Verschoben in den entsprechenden Thread. Gruß Nufan
Andreas01445

Andreas01445

Neues Mitglied
@html6405 bin schon auf die n8010 gespannt
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
Kommt bald, muss leider momentan nur noch auf ein neues Mainboard warten,
was hoffentlich die Tage kommt :).

Lg
 
Z

zoegge

Neues Mitglied
Hallo html6405

Leider stehe ich mit Deinem Rom bereits zu Beginn an und wunder mich soeben selbst wieso ich letzten Sommer ein Rom am anderen laden konnte und hier schon am Anfang anstehe.

Um TWRP zu flashen wollte ich soeben das File über Odin 3.10 unter AP laden. Hier klemmt aber bereits schon das komplette Odin seit Minuten. Das TWRP File ist ja nur um die 53 Bytes, dass sollte doch schneller gehen. Muss ich eine andere Odin Version nutzen?

Lg
 
Z

zoegge

Neues Mitglied
Hallo Nufan

Danke für das verschieben.

Ja, habe zwischenzeitlich weitere 2.8.7 Versionen geladen und die sind in etwa so gross.
Scheint aber dass ich noch nicht das richtige erwischt habe. Bei den beiden letzten Versuchen ist mir Odin abgeschmiert.

Werde Morgen nach der passenden Version weiter suchen.

Danke für Deine prompte Antwort vorhin.

Lg
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
Tut mir sehr leid, wenns fuchst, ich habe oben den Link für das TWRP angehängt,
welches ich verwende. In Odin unter AP einfügen, auto reboot raus, flashen und dann das Kabel abziehen
und mittels Tastenkombi reinbooten.

Lg
 
Zuletzt bearbeitet:
Z

zoegge

Neues Mitglied
Was für ein Service. Riesen Kompliment und vielen Dank.

Bin heute geschäftlich immer wieder ausser Haus und komme nicht zum testen. Habe das Tablet darum auch zu Hause gelassen.
Werde es aber gerne heute Abend wieder in Angriff nehmen und bis Morgen Bescheid geben.

Lg
 
Zuletzt bearbeitet:
html6405

html6405

Gewerbliches Mitglied
Threadstarter
Ok alles klar ;).

Lg
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
Die MD5-Prüfsumme kopierst du mit der Zip einfach auf den internen Speicher (oder SD-Card, je nachdem wie es dir lieber ist) und
TWRP prüft automatisch vor der Installation diese, stimmt die Prüfsumme der Zip-Datei mit der in der MD5-Datei nicht überein,
wird die Installation abgebrochen, dann ist entweder der Download unvollständig oder die Datei wurde manipuliert.

Lg
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
zoegge schrieb:
1.) Wurde das einfrieren der Kamera behoben?
Das Problem liegt an der mitkompilierten Kameraapp, einfach eine andere installieren (Playstore etc) wenns momentan stört ;).
 
Zuletzt bearbeitet:
Z

zoegge

Neues Mitglied
Hallo html6405

Konnte heute Abend Dein lineage auf das Tablet spielen und funktioniert bis jetzt super.
Kann alles stabil einrichten und für das "alte" Tablet läuft es sehr flott - echt tolle Sache.

Danke für das File, Deine Zeit und vor allem für Deine Unterstüzung in meinem Problem. Das hat mich echt gut vorwärts gebracht :1f44c::1f44d::)

Mach mich jetzt an das Tablet GT-P5210 meiner Frau um dies für die 2. bereit zu machen ;)
 
U

undrob

Neues Mitglied
Servus html6405,

ich habe heute die LineageOS und die GAPPS aufgespielt. Bislang hat das experimentelle LineageOS immer Probleme versursacht, so dass mein Tablet das letzte ca. halbe Jahr stillgelegt war.
Die Installation war ein bisschen kniffelig, da irgendwelche Skripte nicht ausgeführt werden konnten (Fehlermeldung bei der Installation von LineageOS). Ein kompletter Boot war nicht mehr möglich, das Lineage-Icon malte sich über Stunden neu :(.

Ich habe dann alle Speicher gewiped und anschließend, wenn von TWRP durchführbar neu mit etx4-FS formatiert. Danach hat die Installation der beiden Pakete einzeln geklappt und ich konnte durchbooten. Root/SuperSU brauche ich nicht. Typischerweise wieder der Fehler mit der Bildschirmtastatur, die nicht erscheint. Lösung: erst einmal W-LAN und Google-Anmeldung abbrechen und dann in den Systemeinstellung die Anzeige der Hardwaretastatur (Einstellungen --> Sprachen & Eingabe --> physische Tastatur --> Bildschirmtastatur anzeigen) ausgewählt. Danach W-LAN und Google-Konto definiert und neu gestartet (PlayStore hat mich vor dem Neustart zwar gekannt, wollte mir aber meine gekauften Apps wieder verkaufen --> Reboot heilt das).

Also: vielen Dank, html6405. Mein N8000 bekommt somit eine dritte Lebenszeit :).
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
Hi,
undrob schrieb:
Die Installation war ein bisschen kniffelig, da irgendwelche Skripte nicht ausgeführt werden konnten (Fehlermeldung bei der Installation von LineageOS). Ein kompletter Boot war nicht mehr möglich, das Lineage-Icon malte sich über Stunden neu :(.
Das wipen ist ein Muss bevor, dann läufts auch, das liegt aber nicht am Rom.
undrob schrieb:
Typischerweise wieder der Fehler mit der Bildschirmtastatur, die nicht erscheint.
das ist kein Fehler, sondern man muss ganz einfach nur die virtuelle Tastatur (Symbol dafür ist rechts unten) beim ersten Start aktivieren, das gehört so ;).
Ich könnte dies allerdings auch standardmäßig auf aktiv setzen.

Lg
 
U

undrob

Neues Mitglied
html6405 schrieb:
Hi,
Das wipen ist ein Muss bevor, dann läufts auch, das liegt aber nicht am Rom.
Wie gesagt, ich habe da davor irgendwas kapuut gemacht. Wipen alleine hat nicht geholfen. Ich beim ersten Versuch heute wieder alles gewipet. Erst beim zweiten Versuch mit dem neu formatieren hat's dann geklappt. Sollte ein Hinweis an andere sein, die ähnliches wie ich verbockt hatten.

html6405 schrieb:
das ist kein Fehler, sondern man muss ganz einfach nur die virtuelle Tastatur (Symbol dafür ist rechts unten) beim ersten Start aktivieren, das gehört so ;).
Ich könnte dies allerdings auch standardmäßig auf aktiv setzen.
Wäre ganz OK, meine BT-Tastatur kann ich erst aktivieren, wenn der Launcher da ist ...

LG
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
undrob schrieb:
Wie gesagt, ich habe da davor irgendwas kapuut gemacht. Wipen alleine hat nicht geholfen. Ich beim ersten Versuch heute wieder alles gewipet. Erst beim zweiten Versuch mit dem neu formatieren hat's dann geklappt. Sollte ein Hinweis an andere sein, die ähnliches wie ich verbockt hatten.
Ok ;),
undrob schrieb:
Wäre ganz OK, meine BT-Tastatur kann ich erst aktivieren, wenn der Launcher da ist ...
das werde ich mir auf jeden Fall vornehmen, für die Meisten die LineageOS bereits kennen ist das meist schon bekannt,
ok ja das mit der BT-Tastatur ist natürlich etwas anderes, aber hauptsache es läuft und das stabiler als wie die experimentelle Version :D.

Lg
 
html6405

html6405

Gewerbliches Mitglied
Threadstarter
html6405

html6405

Gewerbliches Mitglied
Threadstarter
Update:

Ich habe jetzt

TWRP 3.1.1 fürs N8000, N8010 und N8020 gebaut, läuft wunderbar,
Links werden im ersten Post aktualisiert.
 
Ähnliche Themen - LineageOS 14.1 GT-N8000 GT-N8010 GT-N8013 GT-N8020 SCH-I915 Antworten Datum
23
17
3
Oben Unten