Huawei Mate 9 erzeugt fehlerhafte Aufzeichnungen der Adapter-App (Mercedes)

  • 55 Antworten
  • Neuester Beitrag
Diskutiere Huawei Mate 9 erzeugt fehlerhafte Aufzeichnungen der Adapter-App (Mercedes) im Zubehör für Huawei Mate 9 im Bereich Huawei Mate 9 Forum.
E

exodus99

Gast
Hallo,

wie bereits in mehreren Beiträgen von mir erwähnt, habe ich massive Probleme mit den Aufzeichnungen meiner Fahrten mit dem PKW.

Es handelt sich hierbei um die App "Adapter" von Mercedes, der mit meinem Mate 9 gekoppelt ist.

Die App ist mit allen erdenklichen Modifikationen geschützt worden, das diese im Hintergrund weiterlaufen darf.

Um das ganze zusammen zu fassen... Die App wird nicht geschlossen wenn der Bildschirm deaktiviert ist, ebenfalls sind die Optimierungen seitens des Betriebssystems deaktiviert und die App im Tasker mit dem Vorhängeschloss versehen usw....

Dieses Problem zieht sich durch das Mate 7, Mate 8 und auch nach dem neusten Update auf die B138 bei meinen Mate 9 wie ein roter Faden durch die Modellreihe.

Dabei verhält sich das ganze absolut unberechenbar... Teilweise funktioniert das System 1 Tag perfekt, und dann wiederum werden Aufzeichnungen einfach abgebrochen oder finden erst überhaupt nicht statt.
Das ist natürlich ein Problem für ein "lückenlos geführtes Fahrtenbuch" wie es vom Finanzamt vorgeschrieben wird.

Natürlich habe ich nach jeden Update einen Factoryreset durchgeführt und KEIN Backup eingespielt. Bringt aber alles nichts. Wenigstens die Entwickler von Mercedes haben auf meinen Hilferuf reagiert und die Möglichkeit eingepflegt einen automatisierten Sound abzuspielen, wenn eine Aufzeichnung startet.

Wie bereits erwähnt verhält sich das ganze unberechenbar.... Auch wenn die App direkt vor dem Einsteigen neu gestartet wird, ist dieses kein Garant dafür das die App aufzeichnet, da diese ohne Vorwarnung geschossen wird.

Warum wird die App überhaupt geschlossen?!? Auch wenn ich unter Einstellungen/Akku/Zahnrad (oben rechts)/Verlauf der geschlossenen Apps nachsehe, finde ich keinen Eintrag, das diese oder irgend eine Andere App geschlossen wurde.

Im Endeffekt sieht das ganze dann so aus...

Screenshot_2017-01-09-11-03-03.jpg

Trotz allen Modifikationen wird die App durch den "zurück Button" (Dreieck unten links - NAVI Key) geschlossen. Diese Frage hatte ich schon einmal gestellt, aber leider keine Antwort darauf erhalten... --> Probleme mit Push Notifications

Folgende Szenarien:

- Ich starte die App, diese braucht ein paar Sekunden bis diese aktiv ist. Ich betätige den Homebutton (Kreis in der Mitte) und springe in den Startbildschirm. Ich starte die App erneut und diese ist sofort aktiv und muss nicht geladen werden.

- Ich starte die App, diese braucht ein paar Sekunden bis diese aktiv ist. Ich betätige den Tasker (Quadrat recht) und lösche den aktiven Speicher mit de Klick auf das Abfalleimersymbol und springe in den Startbildschirm zurück. Ich starte die App erneut und diese ist sofort aktiv und muss nicht geladen werden.

- Ich starte die App, diese braucht ein paar Sekunden bis diese aktiv ist. Ich betätige den Zurückbutton (Dreieck links) und springe in den Startbildschirm. Ich starte die App erneut und diese lädt komplett neu.
Jetzt meine Frage... Ist da so gewollt oder ein Fehler in Android oder EMUI?!? Fakt ist, beende ich die APP mit dem Zurückbutton, wird die App komplett geschlossen und es erfolgen keinerlei Aufzeichnungen.
Das Thema hatte ich unter anderen hier schon einmal erwähnt --> Eine Woche mit dem Mate 9....... Erfahrungen und Fazit

Auch bin ich nicht der einzige der Probleme mit dem schließen der Apps hat ... Allerdings ist es für mich keine Option das Smartphone zu wechseln, wie es der Threadersteller hier gemacht hat --> "Blitzer DE Plus" beendet sich ständig

Evtl. hat jemand einen Tipp für mich....

Danke

Roland
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Leuter - Grund: Bitte große Bilder spoilern!
N

n1LzZ

Ambitioniertes Mitglied
Hast du schon mal ausprobiert unter Einstellungen ==> Apps ==> Einstellungen ==> Spezieller Zugriff ==> Akku-Optimierung ignorieren über den blauen pfeil deine App als "Zulässig" hinzuzufügen?
 
E

exodus99

Gast
Aber klar doch,

hatte ich bereits erwähnt...

exodus99 schrieb:
Um das ganze zusammen zu fassen... Die App wird nicht geschlossen wenn der Bildschirm deaktiviert ist, ebenfalls sind die Optimierungen seitens des Betriebssystems deaktiviert und die App im Tasker mit dem Vorhängeschloss versehen usw....
Ich kann auch gerne nochmal alles zusammenfassen was ich bereits ein- bzw. umgestellt hatte.

- Keine Backups eingespielt, immer neu installiert. (funktioniert bei dieser App sowieso nicht)
- unter Einstellungen/Mehr/Mobilfunknetz/Mobile Daten immer aktiviert (Regler nach rechts) auf an.

- Einstellungen/Apps/Einstellungen/Spezieller Zugriff/Akku-Optimierungen Ignorieren/auf - zulässig
- Einstellungen/Apps/Einstellungen/Spezieller Zugriff/Systemeinstellungen ändern/Systemprozesse anzeigen/wird nicht aufgeführt
- Einstellungen/Akku/Apps nach Sperren schließen/jeweilige App auf aus (Regler nach links)
- Einstellungen/Akku/ Nix Stromsparmodus oder Ultra (beide Regler auf links)
- Im Tasker (Quadrat in der Navileiste)/ die Apps mit einem Vorhängeschloss gesichert
- Einstellungen/Akku/Zahnrad oben rechts/Zu stromintensive Apps beenden--> Regler links, auf aus.
- Unter Einstellungen/Akku/Zahnrad oben rechts/Verlauf der geschlossenen Apps wird nichts angezeigt - Anzeige bleibt leer

Einstellungen/Benachrichtigungs & Statusleiste/Benachrichtigungsverwaltung/adapter (so heisst die app)
Benachrichtigung zulassen - aus (Regler auf links)

Einstellungen/Apps/Adapter (Name der App)/Akku/Systemreaktivierung auf an (Regler auf rechts)

Screenshot_20170110-124647.jpg

Trotzdem macht die App nicht das was sie sollte und wird willkürlich geschlossen. ich merke das immer daran, das die App ein paar Sekunden nach dem Aufrufen braucht bis diese nach dem Ladebildschirm angezeigt wird. Ansonsten ist die App sofort verfügbar sobald das Icon angetippt wird.

Gruß

Roland
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Leuter - Grund: Bitte große Bilder spoilern!
N

n1LzZ

Ambitioniertes Mitglied
Okay, hatte ich überlesen. Wurde diese App schon für Android 7.0 angepasst, Finde in der App-Beschreibung dazu nichts. Nur 4.4 und höher.
 
E

exodus99

Gast
Wie bereits geschrieben, bestand dieses Problem auch mit dem Mate 7 und 8, somit Marshmallow und nicht nur Nougat.

Lt. dem Entwicklerteam, mit denen ich in Kontakt stehe, wurde die App für Nougat freigegeben.

Gruß

Roland
 
Q

q2k

Gast
@exodus99
Hatte das Problem mit der Strava-App.Auch keine Lösung gefunden,Mate 9 verkauft und Sony Xperia XZ gekauft.
Problem gelöst und die Mercedes-App läuft auch fehlerfrei.Liegt also nicht an 7.0.
q2k
 
B

baeckus

Erfahrenes Mitglied
Hallo!
Auch bei mir beendet die Outdoorapp Orux nach einer bestimmten die Zeit die Trackaufzeichnung.
Dies passiert allerdings nur, wenn ich ich nur Aufzeichnen lasse, ohne mich routen zu lassen.
Läuft im Hintergrund eine _route, dann wird ohne Unterbrechung aufgezeichnet.
Ciao baeckus
 
E

exodus99

Gast
Da ich mich gerade in einen anderen Thred ausgekotzt habe, möchte ich auch diesen noch auf den aktuellen Stand bringen....

Nach guten 4 Wochen nach dem Update auf die B138 artet das ganze komplett aus... Die App schließt sich nach teilweise schon 5 Minuten und zeichnet keine Fahrten mehr auf oder bricht die Aufzeichnung einfach ab, wie hier schön zu sehen ist.
Screenshot_20170209-160410.jpg

Alle durchgeführten Modifikationen bringen hier leider überhaupt nichts und das Smartphone gaukelt noch einem vor, das die App aktiv ist - siehe folgendes Video


Schließt sich die App, zeichnet sie natürlich keine Fahrten auf oder bricht die Aufzeichnung ab...

Gruß

Roland
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Leuter - Grund: Bitte große Bilder spoilern!
Jupp68

Jupp68

Experte
Das ist mir auch bei dem Emails und WhatsApp aufgefallen, egal was ich mache, es ist nicht nachvollziehbar, habe auch alles richtig eingestellt, bin allerdings auf der 126, zum Glück komme ich klar damit und führe kein Fahrtenbuch, da ist es natürlich ganz übel.
 
Hacki1962

Hacki1962

Stammgast
Kann es nicht sein das es ein Fehler der App und nicht des Gerätes ist? So pralle sind die Rezensionen im Store für die App von Mercedes auch nicht.
 
E

exodus99

Gast
@Hacki1962

da kannst du natürlich recht haben.... Allerdings sind dann die meisten Apps fehlerhaft, denn dies ist ja nur ein Beispiel. Nachdem ich die B138 gute 4 Wochen am laufen hatte, eskalierte das ganze auch mit anderen Apps die vorher keine Probleme machten. Außerdem sieht man im Video schön , das EMUI hier einen vorgaukelt das die App aktiv ist, was sie aber nicht ist.... Das kann nichts mit der App selbst zu tun haben.

Das habe ich auch in einen anderen Thread zusammengefasst, aber interessiert keinen bzw. wurden damit die Forumsregeln missachtet und der Thread geschlossen --> Mate 9 macht was es will, aber nicht was ich möchte!

Ich finde es schade, das auf dieses Thema nicht weiter eingegangen wurde, aber es ist so wie es ist.... Evtl. hat das irgendetwas mit dem Thema zu tun, dass das Mate 9 auch nach längerer Zeit nicht langsamer werden soll.... Zumindest wurde dieses bei der Vorstellung so kommuniziert und in den Vordergrund geschoben.

Das die Rezensionen von Mercedes Me Adapter schlecht ausfallen, liegt hauptsächlich daran, das die App Akku zieht ohne ende, wobei ich persönlich damit kein Problem hätte, wenn dadurch die App anständig arbeiten würde. Dazu muss ich sagen, dass das Entwicklerteam da echt auf Zack ist. Schreibt man den Support an, bekommt man innerhalb 2 Stunden eine Antwort. Aufgrund meiner Beschwerde haben die sogar einen Sound in die App integriert, damit man hört das die App eine Aufzeichnung startet..... oder eben auch nicht. Diese Implementierung erfolgte innerhalb von 48 Stunden, löst aber mein Problem leider nicht. Die App Entwickler können leider nicht in EMUI eingreifen, das offensichtlich dieses Phänomen verursacht und unkontrolliert Apps schließt.
Wie in dem verlinkten Thread von mir erkennbar, warte ich seit ca. Mitte Dezember vergebens auf eine Antwort von Huawei, von einem Lösungsansatz will ich hier nicht mehr sprechen. Fakt ist, das die App auf anderen Nougat betriebenen Smartphones (keine Huawei) alles perfekt aufzeichnet wenn alles richtig eingestellt wurde, allerdings dann viel am Akku nuggelt. EMUI geht da einen anderen Weg... lieber die App schließen und damit den Akku zu schonen. In meinen Augen eine Frechheit, da ich als Besitzer eines teuren Gerätes selber entscheiden möchte, was eine App darf und was sie nicht machen soll.

Auch andere haben Probleme mit Apps die Aufzeichnungen abbrechen, darüber findet man im Forum mehrere Beispiele wie z.Bsp. hier --> Eine Woche mit dem Mate 9....... Erfahrungen und Fazit oder hier --> "Blitzer DE Plus" beendet sich ständig

Gruß

Roland
 
Zuletzt bearbeitet von einem Moderator:
I

Intruder_2000

Fortgeschrittenes Mitglied
Die einen haben das Pech das sich die Apps von alleine deaktivieren und ich habe das Problem das sich meine Apps von alleine aktivieren. Wenn ich könnte, würde ich mein Problem mit Dir tauschen und wir wären bestimmt beide glücklich :D
 
E

exodus99

Gast
@Intruder_2000

ein Tausch wäre wirklich die beste Lösung :)

Im Grunde genommen haben wir aber das selbe Problem.... EMUI macht nicht das was wir wollen und setzt sich über alle Einstellungen hinweg.
Nur das Symptom ist ein anderes... Bei dir gehen die Apps von alleine an und bei mir von alleine aus...

Interessant für mich wäre, wenn du hier deine Einstellungen bzw. durchgeführten Modifikationen posten würdest. Es ist nicht auszuschließen das in EMUI ein Übersetzungsfehler drin ist, der zu einer "falschen Einstellung" führt und somit unsere Probleme aufruft... Da ich von Huawei im stich gelassen werde, klammere ich mich wirklich an jeden Strohhalm... Meine Einstellungen habe ich ich bereits in diesen Thread gepostet --> Apps werden im Hintergrun geschlossen - fehlerhafte Aufzeichnungen diese sollten eigentlich verhindern das eine App in den Schalf versetzt wird, tut es aber nicht... Jetzt wäre wirklich interessant was du bei diesen Optionen eingestellt hast und dein WakeUp Phänomen auslöst...

Gruß

Roland
 
I

Intruder_2000

Fortgeschrittenes Mitglied
Huawei hat manchmal eine komische Art auf Fragen zu antworten... bei mir war´s am Thema vorbei aber das da unten...
aber dennoch habe ich bei mir alles so eingestellt wie der Support es mir mitteilte:

3. Der Telefonmanager des Huawei Mate 9 überprüft den Stromverbrauch von allen installierten Apps und warnt Euch, wenn eine von ihnen besonders viel Energie verbraucht Die Benachrichtigungen lassen sich sowohl komplett als auch gezielt für bestimmte Anwendungen deaktivieren Ihr könnt auch einstellen, dass Euer Smartphone Anwendungen mit einem besonders hohen Stromverbrauch selbstständig beenden darf.
Die Benachrichtigung habe ich drin gelassen - es macht ja nichts wenn ich nur die Meldung beseitige aber die Ursache weiterhin besteht.

Aktiviert dafür die Option "Einstellungen | Akku | Einstellungen | Zu Stromintensive Apps beenden"
Stellt den Schalter unter "Einstellungen | Akku | Einstellungen | Stromverbrauchs-Warnung" auf "aus", um alle Warnungen abzuschalten
Unter "Einstellungen | Akku | Verbrauch" könnt Ihr in der Liste der Anwendungen mit dem höchsten Stromverbrauch auch Warnungen für bestimmte Apps gezielt deaktivieren
Bei meinem Prime Video, welches sich auch von ganz alleine startet, gibt es unter dieser App ein Menupunkt "Akku". Dort habe ich die Schalter "Systemreaktivierung" deaktiviert - damit die App vom System nicht von alleine gestartet werden darf - machts aber anscheinend dennoch.
"Schließen nach Bildschrimsperrung" aktiviert... Wenn der Bildschrim geschlossen wird, wird die App deaktiviert - funktioniert manchmal - manchmal auch nicht^^

Dieses "Systemreaktivierung" gibts nicht bei allen Apps. Also nicht das Du vergeblich nach suchst wenn Deine App es nicht haben sollte.

Bei Amazon Music fehlt der Punkt "Systemreaktivierung" zum Beispiel.

Bei mir ist auch das kuriose das sich die beiden Apps, abhängig der Internetverbindung aktivieren.
Unter WLAN z.B. immer Prime Video
und unter Mobilen Daten Amazon Music.
Kein Internet = Ruhe!!! Kein selbsständiges starten mehr.

Vielleicht will Deine App auch Internet - oder er will keine?!? Ich hab echt kein Plan.

Mehr Infos konnte ich bis jetzt leider nicht finden.

Das letzte Smartphone, das so viele Probleme machte, war ein O2 XDA (glaube Orbit) mit Windows Version "schlagmichtot" - obwohl das keine Bugs hatte sondern ständig einfroh und sich von alleine neu bootete. Windows halt^^
 
koho

koho

Lexikon
@exodus99
Mal blöd gefragt: ein Wechsel des Handys kommt für Dich nicht in Frage?

Wenn es bei mir um Dinge wie Finanzamt/Steuern ginge und auf das Teil kein Verlass ist dann wäre bei mir schon längst die Schmerzgrenze erreicht und ich hätte ein Handy bei der die Aufzeichnungen funktionieren anstatt mich monatelang zu ärgern und vergeblich zu hoffen.
 
Hacki1962

Hacki1962

Stammgast
@exodus99
Das meine ich bei der App, durch den hohen Akku verbrauch könnte es ja sein das eben deshalb das System eingreift vielleicht is nicht einmal Huawei schuld sondern Google Android. Kann jetzt nicht sagen das ich Probleme mit meinem Gerät habe bei mir funktioniert alles so wie ich es mir vorstelle.
 
E

exodus99

Gast
@Hacki1962

genau aus diesen Grund habe ich alle Optimierungen seitens Android deaktiviert, das eben diese App nicht geschlossen wird. Aber wie auch in vorangegangenen Versionen von EMUI setzt sich diese Version über alle Einstellungen hinweg. Und nein, es liegt nicht an Nougat, da diese App auf anderen Geräten, bis auf den hohen Stromverbrauch, das macht was sie soll... Also liegt es an EMUI - Huawei, wie meistens...
Es ist schön das bei dir alles so funktioniert wie es soll, aber ich gehe mal davon aus das du keine App in so einer oder ähnlichen Art am laufen hast. Somit bist du die perfekte Zielgruppe für ein Huawei Gerät :)

@koho

wenn du mir eine anständige Alternative nennen kannst, ich habe dafür immer ein offenes Ohr. Ansonsten habe ich seit gestern ein Iphone im Auto, das mit der Adapter App alles aufzeichnet wie es soll... Nur blöd das ich darauf nicht vorher gekommen bin.... Hätte mir viel zeit und Ärger erspart - ist aber auch nur eine Übergangslösung. Leider kann ich aus Sicherheitsgründen das Iphone und das Mate 9 nicht parallel auf den Adapter zugreifen lassen, hier lässt Mercedes immer nur eine Verbindung zu :-(

@Intruder_2000

Danke für die Offenlegung deiner Konfiguration, bei Gelegenheit werde ich das mal testen...
Die Adapter App von Mercedes hat den Button "Systemreaktivierung", was man auch weiter oben gut erkennen kann --> Apps werden im Hintergrun geschlossen - fehlerhafte Aufzeichnungen

Ansonsten hat die Adapter App alle Zugriffe was ein modernes Smartphone bietet...

Gruß

Roland
 
AlicaFabienne

AlicaFabienne

Experte
Kann viele hier beschriebene Probleme von @exodus99 und auch aus dem leider geschlossenen Thread
Mate 9 macht was es will, aber nicht was ich möchte! bestätigen. Probleme und Pushaktivitäten, auch die ohne Muster mit Wechselwirkungen werden mit der Zeit schlechter. Das war leider schon so beim P9.

Mein 1jähriges Huawei Nexus 6P (Huawei Hardware mit Google Software 7.1.1) mit exact gleichen installierten Apps wie das Mate9 macht was es soll, deshalb bereitet mir derzeit mein Nexus 6P deutlich mehr Spass und Freude als mein Mate 9.
 
E

exodus99

Gast
@Intruder_2000

habe heute die Adapter App von Mercedes wieder auf meinen Mate 9 installiert und mit deinen Angaben konfiguriert.... Resultat, die App wird nach ca 2 Minuten geschlossen nachdem der Bildschirm aus ist. Somit noch schlimmer als vorher und von automatischen reaktivieren ist nicht die Spur zu erkennen...

Noch etwas OT... Mein Mate 9 dreht jetzt komplett am Rad... Ich kann keine Nachrichten mehr vom Sperrbildschirm aufklappen, geschweige denn öffnen und direkt in die App springen (von solch einen Problem habe ich hier schon mal gehört und es gab dazu auch ein Video). Benachrichtigungen werden angezeigt und dann ist es als ob der Sperrbildschirm einfriert und lässt sich nur noch mit einem Wisch zum Startbildschirm öffnen.
Zum Thema Adapter App und Iphone... Jede Fahrt wurde fehlerfrei aufgezeichnet, genauso wie es sein sollte. Einzige Ausnahme war gestern früh die erste Fahrt, da war der Akku vom Iphone leer. Der schafft eben kein Wochenende :) Ich habe zwar den DriveKit+ für das Iphone in meinem Mercedes, dieser lädt das Gerät aber nur wenn die Zündung an ist... Das glaube ich kann ich aber umstellen (lassen) und somit ist das Problem für mich Geschichte.

Gruß

Roland
 
I

Intruder_2000

Fortgeschrittenes Mitglied
Schade das es nicht klappte :( Aber wäre ja auch zu schön um wahr zu sein. Ich habe bei mir auch einen Weg gefunden das meine Apps frieden geben. Meine aktuelle Lösung = kein Internet. Internet nur aktivieren wenn ich es benötige und schon funktioniert alles einwandfrei. Kein Plan warum das so ist :/

Eine dauerhafte Lösung ist es allerdings keine. Das gebe ich zu.