Magic Earth - Bugs / Fehler

K

kddh

Erfahrenes Mitglied
Threadstarter
In diesem Thread möchte ich die Bugs / Fehler in Magic Earth sammeln.

Ich möchte darum bitten, dass jeder Bug / Fehler separat in einem Post genannt wird. Am besten man erläutert noch etwas den Bug / Fehler, unter anderem in welchen Situationen er auftritt und wie man ihn reproduzieren kann. Wenn andere Nutzer diesen Bug / Fehler bestätigen können, bitte ich darum dies durch den „Danke“-Button zu bestätigen und nicht wiederholt zu posten.

Einen neuen Bug / Fehler dann bitte wieder in einem neuen Post schreiben.

Auf diese Weise möchte ich erreichen, dass der Thread übersichtlich bleibt.

Ich werde in regelmäßigen Abständen die gesammelten Bugs / Fehler an General Magic weitergeben und versuchen hier auch Rückmeldung von General Magic wiedergeben.

Ich wünsche keine Diskussion in diesem Thread, er soll lediglich eine Aufzählung von Bugs / Fehlern werden. Für Diskussionen bitte ich darum, neue Threads zu eröffnen. Danke.


Also:

- jeden Bug / Fehler nur einmal nennen
- pro Post nur ein Bug / Fehler
- Bestätigung über „Danke“
- KEINE Diskussionen

Ich bitte um rege Beteiligung um die App Magic Earth immer besser zu machen.

Danke, und auf eine gute Zusammenarbeit.

Mit freundlichen Grüßen
Carsten
 
rc23

rc23

Stammgast
Im Kartenstil Gelände werden unter Android 5.1 und Android 7.0 keine Sonderziele angezeigt. Link
Diskussion dazu hier ab Posting #3.
 
Zuletzt bearbeitet:
D

derwahreeasy

Fortgeschrittenes Mitglied
Keine Möglichkeit unter Android 8 (Oreo) die OSM-Karten auf einer externen SD-Karte zu speichern.
 
C

copy&paste

Experte
Problem Nachtfärbung
ME-Version: 7.1.17.45.6ccaschlagmichtotwarumAppEntwicklerauchimmersokomischeVersionsnummerngenerierenmüssen :rolleyes:
Gerät: Redmi Note 4
ROM: XenonHD (Android 7.1.2)

Unter Navigation -> Nachtfärbung habe ich automatisch eingestellt, bemerke aber ein unmotiviertes und nicht systematisierbares hin- und herspringen zwischen Tag- und Nachtanzeige. Und da wir hier von Tageszeiten weit nach 22 Uhr sprechen, sollte auch die KI von ME erkannt haben, dass es draußen sehr dunkel ist. Es spielt keine Rolle ob ich im normalen Screen bin, ein Ziel suche oder Zwischenziele definiere. Immer mal wieder wird die Anzeige taghell und blendet mich als auch den Fahrer. Ein Wechsel der Nachtfärbung in "Ein" behält dann korrekt die abgedunkelte Einstellung. Die reine Navigation wird stets korrekt dunkel dargestellt.
Ich teste es die Tage mal auf meinem S4 Mini mit LOS (Android 7) ob es ein Note-Problem ist oder doch etwas allgemeiner.
 
rc23

rc23

Stammgast
Stimmt, dieses Hin und Herspringen zwischen Tag- und Nachtfärbung habe ich ebenfalls beobachtet. Passiert immer wieder, aber unregelmäßig ... ist IMO ein Bug. Nachtfärbung ist auf Automatisch gestellt.

Bei mir zur Zeit im Einsatz: Samsung Tab A (7" Display) mit Android 5.1.1.

@copy&paste Danke für die gute Beschreibung des Bugs und der technischen Randdaten wie Android-Version und eingesetztes Smartphone oder Tablet
 
Zuletzt bearbeitet:
D

derwahreeasy

Fortgeschrittenes Mitglied
Diesen Fehler kann ich nicht bestätigen.
Habe acu auf "auto" stehen und es wird konsequent und einmalig, in die jeweilige Richtung, umgeschalten.
Sprich, wenn Umschaltung auf "Nacht", dann bleibt dies auch eingestellt, wenn Umschaltung auf "Tag" (in der Automatik), dann bleibt auch dies erhalten.

Ergänzung: weder auf Android 7.1.2 noch auf 8.0 und den jeweiligen Sony-Telefonen
 
Donatello

Donatello

Neues Mitglied
Fehlende Darstellung der POI-Icon importierter POIs (GELÖST):
Die zu den POI-Gruppen (z. B. Krankenhäuser oder Tankstellen etc.) zugehörigen Icons, die beim Download der kml-Dateien mitgeliefert werden, werden nach dem Import in MagicEarth leider nicht in der Karte und auch nicht in der POI-Liste dargestellt. Stattdessen wird ein Platzhalter-Icon angezeigt. Somit wird das Erkennen eines bestimmten POI (z. B. Krankenhaus) auf der Karte sehr viel schwieriger.
(siehe auch meine Beiträge unter MagicEarth-Wünsche und Tipps und Kurzanleitungen zu MagicEarth)

Lösung siehe hier im Forum "Tipps und Kurzanleitungen zu Magic Earth"
 
Zuletzt bearbeitet:
D

derwahreeasy

Fortgeschrittenes Mitglied
In meiner App-Version hängt sich die App auf, wenn ich Zielwahl über Karte manuell durchführen will. Das heißt, sie friert schon ein, wenn ich die Karte unter dem Zielkreuz verschieben will.
 
Donatello

Donatello

Neues Mitglied
@derwahreeasy:
Bei mir läuft ME in der aktuellen Version auf einem Samsung Galaxy Tab 4 | 10.1 | Android 5.0.2 | Micro-SD mit 64 GB.
Das Problem "Manuelle Zielwahl in der Karte" tritt bei mir in dieser Konstellation nicht auf.
 
Zuletzt bearbeitet:
D

derwahreeasy

Fortgeschrittenes Mitglied
@Donatello Ja, das ist schön für Dich. Ich habe jedoch ein modernes Gerät, mit aktuellstem Betriebssystem und aktuellstem Sicherheits-Patch, und da tritt es auf. :glare:
 
Donatello

Donatello

Neues Mitglied
@derwahreeasy Meine Info ist ausschließlich dazu gedacht, die Fehlersuche einzugrenzen und damit zu erleichtern!

derwahreeasy schrieb:
@Donatello Ja, das ist schön für Dich. Ich habe jedoch ein modernes Gerät, mit aktuellstem Betriebssystem und aktuellstem Sicherheits-Patch, und da tritt es auf. :glare:
 
D

derwahreeasy

Fortgeschrittenes Mitglied
@Donatello Das vieles bei den veralteten Android-Varianten funktioniert, ist denen vom Support klar, das weiß ich aus meiner Mailerei mit denen.
Die sind nur schlicht und einfach nicht up to date mit den aktuellsten Android-Versionen.
 
T

Trauco

Neues Mitglied
Moin,
ich nutze die App schon seit mehreren Monaten in der jeweiligen aktuellen Version bislang ohne Probleme.

Jetzt tritt bei mir folgender Fehler auf:
Bei jedem Start der App sind alle persönlichen Einstellungen auf die Standartwerte zurückgesetzt.

Ich vermute, dass es mit meinem neuen Smartphone zusammen hängt. Ich nutze die App auf einem ZTE Blave V7 Lite mit Android 6.0. Die App ist auf der SD-Karte installiert.
Bei meinem bisherigen Smartphone, ein ZTE Blade V452 mit Android 5.1 tratt dieser Fehler nicht auf.

Ich habe mich gestern per E-Mail an den MagicEarth Support gewandt, aber noch keine Antwort erhalten.

Kann von einer von Euch diesen Fehler bestätigen ? Und was könnte die Ursache hierfür sein ?

Mit freundlichen Grüßen
Trauco
 
Donatello

Donatello

Neues Mitglied
Moin Trauco,
an Deiner Vermutung könnte was dran sein. Auf meinem Samsung Tab4 mit Android 5.0.2 läuft ME bis jetzt stabil in der Version 7.1.17.50 (müsste die aktuelle sein); Kartenversion: 7.301 (Das ist die Vorversion, weil ein Kartenupdate bei mir 15 GB hat und meine begrenzte Flat überschreitet).
LG, Donatello
 
T

Trauco

Neues Mitglied
Moin,
ich habe gestern eine Antwort vom Support erhalten. Es wurde vermutet, dass die Settings.ini beschädigt ist. Es wurde empfohlen die Datei zu löschen. Nach einem Neustart der App wird dieses Datei automatisch neu erstellt.

Allerdings war der Fehler nur kurz behoben.

Ich habe jetzt folgendes Verhalten festgestellt:

Wenn ich die App an einer neuen Position öffne, wird die Karte sofort automatisch an die aktuelle Position verschoben. In diesem Fall werden die Einstellungen zurückgesetzt.

Es kommt aber auch vor, dass beim öffnen der App an einer neuen Position die Karte die letzte Position anzeigt. In diesem Fall bleiben meine Einstellungen erhalten. Auch wenn ich auf den blauen Positionspfeil drücke und dann die Karte zur aktuellen Position wandert.

Ich habe versucht den Support diesen Verhalten mit meinen eingeschränkten Englischkenntnissen zu erläutern.

Mal sehen ob es eine endgültige Lösung gibt.

Man kann aber schon mal festhalten, dass einem seitens des Support geholfen wird :smile:

Mit freundlichen Grüßen
Trauco
 
rc23

rc23

Stammgast
Trauco schrieb:
Moin,
ich habe gestern eine Antwort vom Support erhalten. Es wurde vermutet, dass die Settings.ini beschädigt ist. Es wurde empfohlen die Datei zu löschen. Nach einem Neustart der App wird dieses Datei automatisch neu erstellt.
Meistens kommt bereits am Folgetag eine Antwort, aber gebt bitte dem Support zwei bis drei Tage Zeit zum Antworten. Magic Earth liefert verglichen z.B. mit TomTom einen um Klassen besseren und schnelleren Support.

Wenn ich die App an einer neuen Position öffne, wird die Karte sofort automatisch an die aktuelle Position verschoben. In diesem Fall werden die Einstellungen zurückgesetzt.

Es kommt aber auch vor, dass beim Öffnen der App an einer neuen Position die Karte die letzte Position anzeigt. In diesem Fall bleiben meine Einstellungen erhalten. Auch wenn ich auf den blauen Positionspfeil drücke und dann die Karte zur aktuellen Position wandert.
Welche persönlichen Einstellungen werden überschrieben? Hatte bisher bei mir dieses Phänomen noch nicht. Nach allen SW-Updates blieben die persönlichen Einstellungen erhalten. Also, bitte genau angeben, welche persönlichen Einstellungen verloren gegangen sind.

Ich habe versucht den Support diesen Verhalten mit meinen eingeschränkten Englischkenntnissen zu erläutern.
Tipp: Hier ein Online-Übersetzer, den ich auch immer wieder mal nutze, da er eine super Übersetzungsqualität lieferft. Deshalb sucht den direkten Draht zum Support, der sehr offen und freundlich reagiert.

Man kann aber schon mal festhalten, dass einem seitens des Support geholfen wird :smile:
Wie gesagt, s.o.
 
Zuletzt bearbeitet:
T

Trauco

Neues Mitglied
Moin rc23,

rc23 schrieb:
Welche persönlichen Einstellungen werden überschrieben? Hatte bisher bei mir dieses Phänomen noch nicht. Nach allen SW-Updates blieben die persönlichen Einstellungen erhalten. Also, bitte genau angeben, welche persönlichen Einstellungen verloren gegangen sind.
Alle Einstellungen werden auf die Standartwerte zurückgesetzt. Dies tritt im laufenden Betrieb auf. Den genauen Ablauf habe ich oben beschrieben.
Dies hat nichts mit einem Update der App zu tun.

Der Support kann den Fehler nicht nachvollziehen und hatte mich darum gebeten, die Settings.ini (einmal vor dem Fehler und nach dem Fehler) zu übersenden. Dass habe ich gemacht. Mal sehen ob dies dem Support weiterhilft.

Ich behelfe mir jetzt damit, dass ich eine Kopie der Settings.ini mit meinen persönlichen Einstellungen separat abgespeichert habe und diese bei Bedarf wieder in den Ordner "Magic Earth" kopiere.
 
rc23

rc23

Stammgast
@Trauco: Zum Problem "persönliche Einstellungen gehen verloren" unter Android 6.0 stehst Du im Kontakt mit dem ME Support. Hast Du dafür eine Ticketnummer bekommen? Beginnt üblicherweise mit C. So könnte ich nachfragen, ob es vergleichbare Fälle gibt, die den gleichen Fehler zeigen.
 
T

Trauco

Neues Mitglied
Moin rc23,
Eine Ticketnummer habe ich leider nicht erhalten.

Gruß
Trauco
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von derstein98 - Grund: Direktzitat entfernt - Bitte Forenregeln beachten
A

Absolut-Beginner

Neues Mitglied
Seit dem Update meines Nokia 8 von Android 7 auf 8 werden Navigationsansagen nicht mehr via Bluetooth in mein Car-Multimedia-System (Toyota) übertragen. Ich behelfe mich jetzt mit der "AudioBT Plus"-App, aber das ist eine Notlösung. Ich habe diesen Bug schon General Magic mitgeteilt, die mich nur auf kommende Updates vertrösteten, die aber nicht kommen :-(
 
Ähnliche Themen - Magic Earth - Bugs / Fehler Antworten Datum
2
11
22
Oben Unten